Firmware upgrade failed: "Not enough space for response file"


#1

I tried to update my firmware from R9.4b to R9.5d on my SNAP-PAC-R1 but received the following message: “Not enough space for response file.” Then PAC Manager attempted to install a bridge firmware but failed and prompted me to see KB82101.

The knowledge based article described an issue for PAC Manager version R9.2c however I am running PAC Manager version R9.4c.

In the PAC Managers users guide(document 1704) it mentions on p207 “If download fails… there might not be enough file space for the new firmware” so I checked using PAC Terminal and found there is 2 MB of File Storage RAM available. The size of the downloaded firmware file is 2166KB. I thought my controller only had 2MB allocated to file storage anyway so how am I supposed to install the firmware? Seems like I am missing a few steps.


#2

When that update failed, did your firmware version still show R9.4b?
Also, I just emailed you a copy of R9.5a, I’ve seen some cases where upgrading first to R9.5a, then going to a higher version (like the d you tried) works okay. Let us know how you go so we can get the docs, etc. updated. We’ve also made some improvements to PAC Manager, so consider upgrading your software to 9.5 as well.


#3

Yes the firmware showed version R9.4b after the failed update. Ok, I will try upgrading to R9.5a first. Will check back in tomorrow to update how it turned out. Thanks.


#4

I also had this problem when I first upgraded SNAP-PAC-R1. Replace a PC (from windows XP to Windows 7) to upgrade, all right. Try it


#5

@mstjohn I just realized the message with the R9.5a firmware was not delivered to my inbox because of a filter set up on outlook. Could you please send again? I changed up some filter settings and am hoping it will work now. Also - did you guys take down your ftp site with all the archives? I tried accessing but site can’t be reached.

-Prianka


#6

Hi Prianka,

The ftp site should be good (better than email, actually, should’ve thought of that first – my brain is still partly on holiday!).

Can you access: this link? ftp://ftp.opto22.com/Public_Folders_(Unsecured)/Archives_(Software_and_Firmware)/Firmware_Archives/SNAP-PAC_Firmware_Archives/Released/R9.5a

Thanks,
Mary


#7

Thanks! I have not been able to access the Opto 22 ftp site on my work computer since yesterday, however I have been able to access it in the past. Possibly advanced security settings were changed on my company’s firewall? Not sure.
But I just checked and I am able to access the ftp site on my phone so I will get the file from there.

Will update in a bit after trying out.
-Prianka


#8

Unsuccessful again. According to PAC Manager I successfully installed the R9.5a firmware, but when I went to the inspect screen the old firmware was shown (R9.4B). Despite that, on a futile attempt I went ahead and tried to install version R9.5d and ended up with an error message saying “Could not access ‘Response’ file”

Here are pictures with the details discussed:
In the following image you can see that the firmware version R9.5a was successfully installed.

Then when I went to check the firmware version it still shows the older R9.4b version is on the controller.

Still, I decided to try and reinstall the R9.4d firmware version anyway to see what would happen. During what looked like the installation process the message “Waiting for response” was displayed for longer than expected in the results box.

After a waiting 10 seconds or so the final result was “Could not access ‘Response’ file” was shown and as expected the firmware version did not change when I checked the inspect window.

Any thoughts on where I should go from here?


#9

Bummer, thanks for the nice screen shots. I’ve forwarded your info to our support team, you should hear from them soon.

In the meantime, I’d still recommend trying PAC Manager 9.5 (it has a few more options in that “Command” list vs. the one you’re using here).


#10

Oh yeah, ok. I forgot about that suggestion. I will download.
Also, thanks for your help and forwarding to support.


#11

It looks like you’re running into KB86237. Here’s a link to the current version of PAC Manager.

Please let us know if this resolves the issue.


#12

Upgrading to the latest version of PAC Manager, R9.5b, did not help in this situation.

I installed PAC Manger R9.5b via the PAC Project R9.5003 download and tried to install firmware version R9.5d and it returned with “Not enough space for command file” and then moved on to try and install a bridge firmware file which ultimately failed in downloading, it pointed me to KB82101 which is not relevant to my situation.

I then tried to install firmware version R9.5a and it did the same thing as my previous post where it claimed to install successfully but still displayed as having the older R9.4b firmware version on the inspect screen. I tried installing firmware version R9.5d right after and I was met with the “Not enough space…” message like I just mentioned.

The following pictures contain more details:


#13

Thanks for the feedback. The next steps would be:

  1. If the ETHERNET 2 interface is configured, write down the current parameters, and then use the PAC Manager Status Write page to set it back to 0.0.0.0 (all ETHERNET 2 fields). Be sure to click the Apply button.

  2. Then use the Status Write page to “Reset to defaults and Restart device.” Be sure to click the Send Command button.

  3. Then install firmware R9.5a.

  4. Then install the desired firmware version.

  5. Then use the Status Write page to configure the ETHERNET 2 interface again.


#14

Just repeated the steps you outlined and it was a no go. But thanks for the suggestion.

PAC Manager inspect window after “successfully” installing firmware version R9.5a:

Just for fun I tried installing the latest firmware to see what would happen.
Here is the PAC Manager maintenance screen after failing to install firmware version R9.5d:


#15

Let’s take another approach.

  1. Go to our FTP site at ftp://ftp.opto22.com/ and download bridge firmware S9.6a to your computer.

  2. Reboot the controller either by using PAC Manager’s Status Write page or by cycling power to the unit.

  3. Install bridge firmware S9.6a on your SNAP-PAC unit.

  4. Inspect the unit to determine if firmware S9.6a was loaded properly.

  5. If S9.6a firmware installation was successful, then install the current firmware version, which is R9.5d.

  6. If S9.6a firmware installation was not successful, then what error response did you receive?


#16

If the S9.6a firmware installation was not successful, then it would be best to reset the R1 to factory defaults, then reassign the IP address, but only for the primary Ethernet 1 connection, and then try installing firmware again.


#17

After a great amount of troubleshooting it was found that the controller was programmed with a private key via SSD, which only allows firmware signed with the private key to be uploaded and installed - at least I am assuming it was since using the “Clear Key” option in PAC Terminal SSD for the controller (which clears out the firmware and requires it to be installed again) allowed the latest firmware version to be installed. It did not occur to me at first that the controller was still signed with the SSD key (or that it would have an effect on upgrading firmware).

Thank you for taking the time to answer my post.