Firmware update broke OPC-UA between groov View and codesys


I updated the firmware 3.4.5-b.328 to the GRV-EPIC-PR1 I’m working on and after restoring the groov View project and in Codesys rescanning the network and disabling the user management the system should be as it was prior to the firmware update (when everything was working), but alas the groov View cannot access the OPC-UA anymore on the Codesys… the groov View logs say something about identity certificate “An error occurred while generating our OPC-UA application identity certificate. OPC-UA probably won’t work!”

Any hints on fixing this? I’ve been trying to configuring the “device” again in groov View etc. but nothing is working…

Thank you!


Hi there and welcome to the Opto22 forums!

When you install new firmware, a new SSL certificate is created on the groov EPIC.
Sounds like Codesys has still got the original certificate (I am not really up-to-speed on Codesys sorry) and so the communications between the two can not be correctly encrypted.

Have you tried downloading the certificate via groov Mange and installing it into Codesys just like you did when you got it going the last time?

I assume that Codesys is running on the same controller than groov View.

Did you check if Codesys is running correct and that the Tags are made available to a OPC UA client in the Symbol Configurator of the Codesys IDE?

1 Like

Hello, and thanks!

I just actually reinstalled the newest firmware and now it worked like a charm just by rescanning the network and disabling the user management in codesys.

Maybe I broke something when I initially installed the Ignition 8 version of the firmware and played around a little bit with it… Now I installed Ignition 7 version of the firmware and did not touch Ignition.


1 Like

Yes, they run in the same controller. Yes all tags were still selected in the Symbol Configurator and even tried resetting them etc. Did not help.

As mentioned in other reply, I just reinstalled the firmware and it worked just fine.


There’s a bug in the 3.4.x series of EPIC releases where sometimes groov View’s OPC UA directory gets created with the wrong permissions and it can’t write to it, and that interferes with talking to OPC UA. It’s fixed in the next release, but if you run into it again Product Support can help you work around it.

The knowledge base article for it hasn’t been published yet, but it should be KB90619 when it is.

Ok thanks! I’ll keep that in mind.