EPIC USB Serial


#1

Hi, I can not get the serial usb to work on the EPIC.

Using the USB port 0, it appears in the Manage-> System-> Serial Devices as / dev / ttySer0 and Port Number 0. I have tried:

1- With pac control 10 and a comm handle “ser: 0, …”, the OpenOutgoingCommunication command returns a -49 (nobody else is using it)

2- Node-Red with the strategy stopped and the node-red-node-serialport configured as /dev/ttySer0 or /dev/ttyUSB0 returns a Permission Denied error, can not open /dev/ttySer0

The device I am using has worked on linux, windows, mac …

clues?


#2

Good news… we have been able to reproduce your Node-RED issues and we can confirm its a bug.
The bit of bad news is that it is going to take some time to get a fix and issue an update.

On PAC Control. This should work.
I am setting up a serial device at my desk, but in the mean time; does this image help?


#3

I can confirm that Ben’s serial setup works, but it is very flaky. I was able to get Modbus RTU working, but I had to have the opposite settings for bit parity. If my end user device was even, I had to use none. If the parity was none, I would have to use even. It was bizarre, and I have since gotten some R2’s with a rack and RS485 module and attached it as IO to the groov epic. Hopefully a serial card is released soon… I have lots of units to build, but not at this added cost.

Overall, the EPIC is a phenomenal device, I am having lots of fun getting it working with other groov-epic devices with node-red!


#4

Thanks for your sharing.
From your information, the even and none need to be inverse.
Then how about odd ?


#5

When this bug will be fixed?


#6

The EPIC serial module is just about ready to be released… Hopefully this month (September).
There are 4 ports per card and you can configure each port to be a different type of serial (232, 422 or 485).


#7

It will be very expensive if only need one serial port in EPIC.
So, the USB-to-Serial Converter is the best solution.
When this bug will be fixed?


#8

If you’re desperate, get an Ethernet to serial bridge. I believe you can get these with one or multiple serial ports. Also, if you use Mikrotik, I think you can use it as a serial bridge (as well as switch/router) to the USB port on it.