Daylight saving time

I guess groov doesn’t recognize daylight saving time?

Worked Ok for me here.
Do you have an NTP server configured correctly?
Do you have a gateway configured correctly?
Do you have a DNS server configured correctly?

To set the time, the EPIC (and RIO) needs to have a timer server set correctly, it needs to be able to reach the time server and if its a named time server, it needs to have a DNS setup.

It should nowadays. It used to take a restart to get time zone changes to take effect, but I think I have that fixed now. With the possible exception of trends: you may need to refresh your page to see the DST change.

Beyond that though: what platform are you running groov View on, and where were you seeing the incorrect time?

If on EPIC, what version firmware are you running? As @Jonathan_Fischer said, he fixed it, but if you are on an older firmware version it might not have sprung forward for you.

Switched over for me, no problem.

groov Box (AR1), groov EPIC (PR1), and groov RIO (R7-MM1001-10) (all latest public firmware, all using DNS, all offset from UTC) switched over for me without problems.

4 EPIC deployes in different plants and 1 at home, ALL switched automatically with no issues at all.