Data to Groov From Business Network


#1

Hello,

We have a groov that is set up as using the ETH0 port to our business network via a direct fiber connection. ETH1 is on a plant network via a direct copper connection. We have S1 PAC’s on the plant network, and we have an R1 PAC on the business network.

We are using the groov to display data from the plant network to the business network.

We want to display data from the R1 that is on the business network using the groov.

How can we get the R1 to send data to the groov from the ETH0 business network side?

If that is not possible, can we send data from that R1 to a database located on the same business network?

Thanks,

Malcolm Fox
City of Mt. Pleasant


#2

Few questions here, so lets break it down. If I get any wrong, just let us know and we can get you sorted…

  1. To view groov data from the R1, just go into groov Build and put the IP address of the R1 and point to the IDB.txt file, just like you do with the S1 on the plant network.
    Because of the different IP address, groov (should) know to go out the other ethernet port and get the R1 data.

  2. Getting data from the R1 to the database… two ideas.

    1. Use OptoDataLink on a Windows PC on the business network.
    2. Use Node-RED on the groov.

#3

Thanks, I will try that today.


#4

Groov Looking at 2 Ports|666x500

Hi Ben,

I am working in Groov Build from a PC on the business network side. From a browser I can see the Groov display screens.

From my PC I can ping both the business side groov port (192.168.7.150) and the new R1 also on the business network (192.168.8.200). The network switch is routing it across vlans, the default gateway is routing it.

Through the groov plant side network port (192.168.100.100) the groov accesses a PAC S1 at 192.168.100.220, that data is out on the groov screens.

I added the R1 (192.168.8.200) to the groov in the Configure Devices & Tags, and added a variable to a groov screen. Please see the attached screen shot.

It will not display any data. I am still working on it, but it seems to not be able to pull in the R1 through the business side port. I’m not sure it is a groov thing or a network thing.

Thanks, Malcolm Fox


#5

Check your gateway setting on the groov - It will need to know how to route packets from the 192.168.7.0 network to the 192.168.8.0 network. You need to put the gateway for the 192.168.7.0 network as the groov gateway.
Hopefully your plant network does not require routing to other networks, as the groov only supports a single gateway and there is no ability to enter static routes.