Connect Groov RIO to Azure IoT

How do I connect the Groov RIO to Azure IoT Hub and/or Azure IoT Central, When i provide my Azure IoT Hub host name as the Broker URL in the MQTT Config window for the Groov RIO i get an error!

Hi Farhad. Welcome to the Opto22 forums.

Take a look at these forum search results and ask any follow up questions you may have:
https://forums.opto22.com/search?q=Azure

Thank you Beno, the only link that i see that is directly relevant is the one about connecting Snap PAC to Azure IoT using NODE-RED, I am using a Groov RIO, and i was wondering if i could just set the MQTT configurations in the WEB UI for connecting to Azure. Do I have to use NODE-RED for this?

In short. Yes.
Azure is not really MQTT compliant from what I understand, so you will will need to use the node.

ok, so i have been experimenting with node-red and managed to get the groove IO nodes installed and working, When i tried to install the Azure-iot-hub related packages it told me that these packages are deprecated and i should use the azure-event-hub instead. After installing the azure-event-hub packages and setting up the azure-event-hub node with the connection string and the event hub path that i got from my Azure-Iot-hub i get this error:
“TypeError: Cannot read property ‘fromConnectionString’ of undefined”

And when i try to install the azure-iot-central package it fails and says:
“npm ERR! notsup Not compatible with your version of node/npm: azure-iot-device-mqtt@1.16.0
npm ERR! notsup Not compatible with your version of node/npm: azure-iot-device-mqtt@1.16.0
npm ERR! notsup Required: {“node”:”>= 14.0.0"}
npm ERR! notsup Actual: {“npm”:“6.14.12”,“node”:“12.22.1”}

Two different errors there.

This is a Javascript flow error. Something about the way you have setup the connection string.
This should be pretty straight forward to resolve with some debug nodes.

The second install error shows that the NPM version we are running on the EPIC/RIO is currently too old.
I 122% recommend that you DO NOT try and update it. You will have to wait for us to release the updated version in a firmware release ‘coming soon’.

Hi Beno, so while i am waiting on the new firmware i am trying to debug the first error but i am not sure how to proceed, I have not been able to find much info on how to properly set up and debug the azure-iot-hub node. Can you please elaborate on debugging steps? and where i can find more info on setting up that node

@farhad There is a lot of information about the Azure IoT hub here: Azure IoT Hub Documentation | Microsoft Docs

They also have all the node’s source code and other specific information on GitHub here: https://github.com/lcarli/NodeRedIoTHub
Which includes an area for issues, both open and resolved, where you could also reach out to the developers directly if you are experiencing a bug rather than a misconfiguration: https://github.com/lcarli/NodeRedIoTHub/issues

Also, you might find some answers on the Node-RED forums: https://discourse.nodered.org/search?q=Azure%20IoT%20Hub
Since this is not Opto software there’s only so much we can do, but the folks over on that forum may have already dealt with your exact errors!

I hope that helps.

1 Like