Codesys Automation Server

We are looking to use the Codesys automation server to server as a code repository for all of our epics. (~30) Looking at the documentation and from our experimentation we will need to install the CODESYS Edge Gateway on a computer with direct IP access to the PLC. Codesys has a gateway “Codesys for Linux” that we tried to install on the EPIC. We tried to install all of the linux packages available and they all failed with errors in image attached.

Is running the automation server gateway on the EPIC supported? Is there a best practice guide for doing this?


1 Like

You can do either. I have run the Edge Gateway on my laptop or on the EPIC. It is much simpler on your computer. If you want to run it on the EPIC, you need to have a SHELL license to install it, and if you update the firmware you need to be aware and reinstall the edge gateway.

There were some extra steps we had to take when we tested this inhouse(this was back in 2020).

The Gateway is installed when you install the Development System typically.


Thanks, @greichert. We have updated to the most recent firmware (3.5.1-b.85) and we have the SHELL license already applied. We would prefer to run directly on the EPIC so we are not dependent on a Windows machine for access. We have installed the plugins on Codesys and feel like we got it right but obviously we are missing something. Can you elaborate on the “extra steps”? Is there a job we need to run through the SHELL?

Thanks in advance!

Closing the loop on this one. We ran into a blocker running the edge gate for linux on the EPC. The application has a dependancy on the libstcdc++6 & libc6 libraries for the app to work. Neither library is available.

We are going in a different direction and installing this application locally on an edge server.

Thanks for looping back.

We in heavy development of a new Yocto build that will update all the libraries in the kernel.
I suspect that once this is released in the next firmware update, this blocker (and many many others) will be removed.
No solid ETA, but its a few months out at a guess.

Were system libraries updated in the 3.6.0 firmware release? I checked the release notes but didn’t see any information about kernel or library updates.

I know the kernel was not changed, but I am not sure about the library.
@greichert might know more.

Oh, sorry @Indigo, I misunderstood your ‘library’…
I thought you meant Opto22 - Opto 22 Library Package for CODESYS Development System
But I think you meant the libstcdc library… If the latter, then no, this is a firmware update is not the big new Yocto update, it’s still in the works.