Can't Write Tag From Ignition

I have a OMR6 relay module which turns a pump on and off. I have an Ignition project where I have this set up as a Boolean tag. If change the I/O point in my strategy, the value changes in Ignition. If I change the state in Ignition it doesn’t change. I have made the I/O point public and I’ve enabled write communication on the module as well.

I tested this on a simple variable. I can write a value to Ignition but I can’t write from Ignition by to my strategy.

Why doesn’t this work?


Just taking a guess here, have you tried setting it up as an integer instead of a boolean and see if that works?

Yes. I set up a simple Int32 variable. I can see it as a tag in Ignition, I can write a value in the strategy and it shows up in Ignition but it won’t write the other way.

I downgraded PAC Control to 9.6 and everything is working now.

As I suspected, the problem is with PAC Control 10. I think it’s because that version implemented public tags and read/write permissions for those tags and there are still some issues there, at least with regard to Ignition.

I’ve opened a case with Opto support and I will keep you posted.

1 Like

Turns out the fix is to upgrade the Cirrus-Link driver to 3.4.3. That worked for me.

1 Like