Can't Login to Groov Admin


#1

Client calls last week and tells me an AR1 stopped emailing alerts (again). So normally, I login to the UPS that is onsite and turn off the receptacle that powers the AR1. I waited and waited and it seemed the AR1 didn’t power up normally. In a last attempt, I cycled power to the receptacle one more time and walla the AR1 powered back up. I logged on to the APP and sent a test email. Everything worked.
I was contacted again today and they tell me it still isn’t sending event emails. So, I first try to login to the App. Yep, logging in works, sending the test email doesn’t. So I log out of Groov App and try to log in to Groov Admin (I want to reboot the AR1 through the Admin Controls). In the browser, it gives me some generic looking screen to login and it won’t log me in. Please see pictures.


Vs. the App Login Screen:

Any ideas out there?


#2

That groov Admin screen looks like the CSS failed to load. We’ve been seeing some weirdness in Chrome lately when using TLS certificates that aren’t signed by a well-known certificate authority: it lets some things load (like the main index page), but blocks CSS or JavaScript randomly.

Give it a try in Firefox or Edge.

Regarding the email: did it give you an error message when you tried to send the email?


#3

There was no error message. I think you are referring to the actual “Test email” built into Groov. I was not using that. I have a “test email button” or “test event bit” built into my App screen that an operator would use to send a quick email to signify emails are working. So, no… no error message. Just doesn’t send anything.

I’ll try a different browser. Thx


#4

If we ran into an error talking to the mail server, there should still be something that shows up in the system log, regardless of how the email send was triggered.


#5

I found the Groov Log file. What can I type in the search to find any email issues?


#6

I look at the log file and it looks like groov sent a High Level event to my email. I see it in my email with the same time stamp. Then it goes days without any events, but I know I should have got an event ended email for that same High Level event. I know for a fact that the event ended, but no email. The system would have been shut down if that event didn’t end. …Or at the very least I would see in the groov log that someone logged in to view the problem. It is like it quits logging and all events seem to disappear and no emails sent.
Today when I started troubleshooting this problem, I logged into Groov App. I was successful. I clicked my “Test Email” button it intialized, but nothing was sent. So I know for a fact the AR1 was powered up. I wanted to log into Groov Admin, but was unsuccessful. I then decided to cycle power to the AR1 again. After that I was able to log into Groov Admin. I rebooted the AR1 from the Admin console. When I look at the Groov log, it shows the last High Level event began (on the 4th of March) then the next logged event Groov is starting up. That was me restarting it today. So somewhere in there it just stops reacting to events and even logging what is going on. Correct? See below logs. I’m being detailed because I want to figure this out for good.

2019-03-07, 13:15:13 GMT-06:00 INFO com.opto22.groov.server.GroovServletContextListener - Groov is starting up.

2019-03-04, 23:28:23 GMT-06:00 INFO com.opto22.groov.server.notification.EventsProcess - Event ‘T-601 Level is too HIGH’ began at 2019-03-04, 23:28:23 GMT-06:00

2019-03-04, 23:15:16 GMT-06:00 INFO com.opto22.groov.server.notification.EventsProcess - Event ‘T601 Digital Level’ began at 2019-03-04, 23:15:16 GMT-06:00


#7

That does look like something got stuck. You should probably open a ticket with Product Support at this point and send your logs, versions, etc along.