CAN2B initial setup with other IO


#1

I have a training module I am using to test other compact micro controller systems. My CAN2B module is in position 5, and will not “install”. If I follow the procedures, and click “send” the message says “successfully installed 0 of 1 CAN modules”.
If I use the example for RXTX on your website, I cant find anywhere that it assigns the rack number, other than 22520, in one place, which looks like position 10! Is there a way to bypass all the auto-setup stuff and just lock it to position 5 so I can use other modules on the same rack?


#2

If you go into PAC Manager and inspect your controller, on the left hand side go down to Communications>CAN Modules. Here you can select the module position from the drop down to see your CAN Module and all pertinent information (including port number, module position 5 should be 22510).

Now in your PAC-INT-RXTX strategy…
[INDENT]In the Powerup Chart: Modify the code to contain the correct position of your CAN Bus module[/INDENT]
[INDENT][I]Status = O22Can2BConfigMasksFiltersBaud(OptoMMP, [B]5[/B], 250000, 0, 0, 0, 0, 0,0, 0, 0, CANStatus);
[/I]
In the CAN_RECEIVE_ONLY chart: Modify the code to contain the correct port found above, 22510.
[I]CANPort = [B]22510[/B];
[/I]
In the CAN_SEND_ONLY chart; Modify the code to contain the correct TCP address. I am assuming this is a local controller + brain. If you are using a remote brain, use its IP address below.
[I]sTCPHandle = “[B]tcp:127.0.0.1:22510[/B]”;

[/I]In the CAN_SEND_AND_RECEIVE chart; modify the code just as you did in the CAN_SEND_ONLY chart.[/INDENT]

Now your module position is hard coded into the strategy. Please let me know if this helps!


#3

I tried your modifications, but to no avail. pac manager inspection tells me that “module 5 is not a CAN module” I tried unpugging it and plugging it back in, and nothing. At work, i plugged the same module (same model CAN2b, but different actual device) on a rack with a fresh R2 in position 0 and I can inspect it OK. Next thing to try is to take the problem unit back to work and see if it reads on the R2 ok, but this is a new device, so I suspect its something here.


#4

Please consider contacting support@opto22.com for help here, as they’re best equipped to help you troubleshoot. However, a few thoughts in the meantime:

  • I'm hoping when you un- and re-plug in your analog module(s), you're doing that with the power OFF.
  • If one R2 sees the module and another one does not, that would make me suspect that they have different firmware, and the R2 that does not see the module has older firmware (from before that module was added into the firmware).
  • If the R2 does NOT see the module, nothing else is going to work, so that's the first issue you'll need to solve (hopefully w/the support of our support team).

Of course, when you/they do get to the bottom of the issue, I hope you’ll report back here what you find!


#5

>* forehead slap<* updated firmware.