Accessing where Palletes are stored on a AR1

How do you get access to the file system? I installed node-red-contrib-protobuf. To configure it, I need to know where the palette is stored. I though it would be /home/dev/unsecured/sparkplub_b.proto but, that turnout to be not the case since I get a file not found error. The palette says it is installed. Where do these palettes get stored when you install them?

On the AR1 the nodes are installed on this path;

But that is not where the protobuf file is stored.
You will have use another method to copy that file over and depending on what method you use will determine the path.

The path you list in your forum post sounds more like an EPIC (the ‘unsecured’ is a big hint since that path only exists on EPIC PR1 and not the AR1)??

And to answer your first question, from the factory the AR1 does not support SSH or Shell access unlike the EPIC PR1.
You will need to use the ‘exec’ node in Node-RED to do file system commands.

How do I determine where the protobuf file is stored on an AR1? How do even get access to the file directory in order to determine where the file is located?

The protobuf file is not copied over when you install the node. It needs to be transferred over separately.

You could try using the FTP Server node;
Then you can FTP the protobuf file over and in the process you will set the path and so know where it is so you can configure the sparkplug node.

Update. Sorry, thats not going to work… you don’t have control of the AR1 firewall and it will block the FTP server port… I need to think about how to get the protobuf file moved over onto the AR1…

1 Like

Lets say I was to run this in a regular Node Red on a Windows machine. Lets say I install the protobuf and place the sparkplug_b.proto in the public/documents directory. Do you still have to get Windows to yield permission to Node Red?

Looks good to me.
No special permissions needed.

What error do you get when you try it?

With the encode palette, it seems to be ok, I need to do more testing to be sure.
With the decode palette, I get “Profile not ready” and from the debug block I get " No .proto types loaded! Check that the file exists and that node-red has permission to access it." The decode palette is the palette I need help on.

I got some time this morning to circle back around to this…
I am not seeing your error so its hard to pinpoint.

Here is my working decode configuration;

A few things to note.
You must subscribe to a SparkplugB encoded topic. If you don’t you get an error.
You must have ‘Type’ set to Payload. If you don’t you get an error.
You must have the file type set to .proto in the Windows file manager. Note that Windows by default will hide common file extensions like .txt and so the file in Explorer will end with .proto.txt but you wont see it. Go into Windows Explorer and uncheck the hide common file types check box to be sure.

EDIT. Not sure it matters, but I am running my Node-RED on Windows 10 Home edition.