Accessing Files Stored on Groov EPIC in Ignition Edge

I’m using Node-RED hosted on a Groov EPIC to read data from a serial device and write it to a CSV file (stored on the EPIC at /home/dev/secured/…).

I want to pull data from the CSV file into Tags in Ignition Edge (using a script in Ignition Edge). I know how the syntax on the Ignition Edge side of things works, but the function that reads the file in Ignition Edge requires me to specify a filepath.

I tried both of these filepaths in the Ignition Edge script, but both yielded an error saying that the file doesn’t exist.


I actually used the full web address as follows:



This might be a dumb question, but since Ignition Edge is running on the same device that the files are stored on (the Groov Epic), is there any reason I shouldn’t be able to access files stored on the Groov EPIC in Ignition, like I would if it was hosted on any other computer?

This could possibly be due to a bug in my program on the Ignition side, but I wanted to see if it’s at all possible for Ignition to see my locally stored files.

This is likely a user permission issue, i.e. the underlying linux user that has ownership of the folder area.

Do you have the same issue when using the /home/dev/unsecured/ file area?


@matt.karee Do you have a shell license installed?
If so, you can change the directory file permissions as a work around.
I’d need to double check, but I think this will be addressed in an upcoming firmware release, but tweaking the permissions should get you going in the mean time.

1 Like

I’m going to try messing with user permission next, but first I want to make sure I’m entering the filepath in correctly.

I’m seeing in the examples for the function that I’m using in Ignition, that users specify the filepath as


Is there an issue with formatting my file path as follows?


That URL is not a valid LINUX naming standard, so no, you cant do that.

A Linux file name can be up to 255 characters long and can contain letters, numbers, and underscores only . The OS is also case-sensitive, which means it distinguishes between uppercase and lowercase letters in file names.

1 Like

Thank you.

What would a filepath that follows the LINUX naming standard and directs to /home/dev/secured/print_current_setup_command.txt look like?

That looks pretty good right there.
No punctuation, no spaces and using underscores…

1 Like

Hmm okay I’m still getting the same error with that filepath. I will look into changing the directory file permissions.

Interesting update: I tried the exact same method but with that same file stored in


And my error message on the Ignition side changed from “This file does not exist” to “This file isn’t readable”.

So… Ignition can see the file at least!