A problem with R1 firmware

My customer has an R1. He wants to upgrade the firmware. He doesn’t know how to operate. This happens. I’ve never seen anything like this.
Excuse me, what is the reason? How to solve it?

Firstly - as the error suggests, have you confirmed that the controller port is set to default 22001?

As @Jakes said, check that the control engine port has not been changed.
You do this from PAC Manager.

People change the port for different reasons.

The second point: the stopped control engine could be just that the strategy is not running, or there is no strategy, or they are using the R1 as a high speed Ethernet brain and they have turned off the control engine to eek a little more performance and speed out of the R1.

You can check for the latter (the control engine being switched for for more performance) via PAC Manager:

Check the PAC Manager manual for the scanner flag values. (BE CAREFUL! Just changing the flags for no real reason or not understanding them is NOT a good idea).

Now the firmware version of this controller is s9.6. I can’t find this version on the official website of OPTO22. The original firmware version of this controller seems to be r9.5g. I don’t know why it has become s9.6. I wanted to change back to r9.5g, but I didn’t succeed. The prompt is shown in the figure below. “Firmware Update completed,but restart could not be confirmed” why?
Is there a solution?

Did you check the controller firmware version after the update?

You can download the firmware from the opto22 FTP site:

Use Windows explorer to visit the site and dwonload the firmware. Make sure you download the correct firmware for you controller type.

After downloading the r9.5g file, the fault is still the same. R1 failed to install the firmware. I think there is something wrong with the hardware. This is the first time I have seen the controller hardware damaged.

have you done a factory reset on the controller ?
If not, do a factory reset then upload the new firmware

factory reset ? Reset according to the requirements of the manual. It’s useless.

Which reset did you do?
What version of firmware are you running?
Why do you want to change it?

Which reset did you do?
Several methods have been tried,can reset IP. The firmware can be reinstalled, but it is unsuccessful. The prompt "Firmware Update completed,but restart could not be confirmed " appears
What version of firmware are you running?
R1’s current firmware version is s9.6.
Why do you want to change it?
I asked him why s9.6? He told me that the original firmware version was r9.5g and the device was working normally. His new employee downloaded a snap-pac-r1-r10.4c.bin file to upgrade the R1 controller. He told me that the upgrade was also successful, but the firmware version of R1 after the upgrade showed s9.6 instead of r10.4c, and there were two error prompts. I corrected these two errors as required, but I still couldn’t connect with PAC Control Pro 9.6 and couldn’t use it. Two mistakes, as I said earlier.
It does not work with PAC Control Pro 9.6.
My English is very poor. I don’t know whether it is described clearly