Turn off auto scaling with symbols?

Is there a way to turn off the auto scaling in gadgets if i want to use certain symbols? For instance the [%] symbol. I am already scaling in the strategy. To have to scale for this symbol in particular is annoying especially when I want to use the same tag in a trend… now the trend is getting a value of .oo1 so the value gadget can read 1%. Annoying…

I’m not sure what you’re asking here; can you give a more detailed example? What sort of gadget you’re using besides the trend?


These are both from the same exact variable in my strategy. By adding the [%] symbol to the format box the groove multiplies the value by 1000. Why does it do this!?

These are using the L:12 value gadget. If I scale the variable in my strategy to work with this gadget (x/1000), the trend receives the value of [.00x].

Here are some more gadgets with odd scaling or no scaling.

Huh. I had no idea any gadgets did that, it’s not documented in the manual at all, and I can’t find where in the code such a thing is implemented.

This is a bug, pure and simple. No idea why it’s happening yet.

4254% RH, must be somewhere in the south. :slight_smile:

1 Like

Oh, here it is. We pass those format strings through this class before displaying them, and it’s applying the weird scaling. :tired_face:


To turn it off, stick a ’ (quote character, on the key to the left of your Enter key on US keyboards) before the percent sign.


I’d call that an “undocumented feature”!

You can also use the Text Area gadget, shown at the bottom of these three options here:


Here’s a few other notes on text/etc from an older post:

One UI side-note and a pet peeve of mine: do not use that top one (Text Box) for a value that can’t be changed. For example, someone added a value onto a page in our own internal Opto 22 groov pages for “Outside Temperature” but they added it as a Text Box, implying one could type a new number in there that might be more to there liking.

That would be a pretty powerful control program! :wink:

Nah, I’m gonna stick with bug. :slight_smile:

It’s an unexpected side effect of a library that we happen to be using at the moment but aren’t committed to using indefinitely.

I normally don’t. This was for demonstration purposes.

FYI - I use the text area because I can set the text size and then fudge the box sizes to get it to line up how I want. Some of the other tools are not very flexible in this way.

I don’t mind this IF it’s documented. Now that I know how to turn it off this leaves new possibilities.
Are there other special characters that will do something?

Are there other special characters that will do something?

Nothing that looks useful. There are some locale-dependent things for stuff like making sure you’re using the right decimal separator and showing local currency symbols, but only build for the US locale, so it won’t take effect.