REST reading /device/strategy/vars/int64s not working

I get no results when calling

But if I query a specific variable there are results.

I’m on firmware version R9.5d

I was experiencing the same issue with my PAC on R9.5d, upgrading to R9.5g took care of the issue for me and now I’m getting the full array:

Just download the latest firmware and install it onto your device with PAC Manager (full instructions in the user’s guide) and you should be good to go.

Okay, I’ve upgraded to the 9.5g firmware and I’m still getting the same result.

int64s is reporting no variables, but if a singular int64 variable is specified a result is returned.

The unit is a SNAP-PAC-R1 from 2006. By the way the int32s REST call works as expected.

Any ideas what to try next?

The updated firmware should have done the trick.
What browser are you using?
Can you try a different one?

Yes, I have tried in another browser and also with postman. In all cases it returns an empty JSON array.

don’t know if this would have any effect on the behavior, but the strategy that is running on this unit has both of the legacy features enabled under strategy options.

The firmware update got us working, why the same did not work for you is beyond our resources.
Time to get our product support group on the job - they will give you an issue tracking number, that way the software engineers can look at the problem.
Drop them an email; support at opto 22 dot com and outline what you have done and what you are seeing (or not seeing as the case may be).