Please help. Pac R2, S64, and issues with pac display


#1

Setup looks like this,
Snap pac r2
Snap enet s64
Snap enet s64.
We dominantly use AB hmis and plcs, but part of our refrigeration system includes the aforementioned option setup. I spoke with support several times this week about moving float data into the scratch pad in order to retrieve several temperature values to an AB plc.
I went into config, added an action block to move the data. Created two variables. Went to debug and now I’ve lost the connection to the second s64. I cannot get it to connect. I reverted my changes and deleted the two variables. Now I still cannot get it to connect to the s64 and the PAC runtime will no longer open locally. It begins the search for scanners and stops. The refrigeration system and display have been in process for several years.
Any help would be greatly appreciated as I really need to get this running promptly before production fires up.
After reverting all changes I have tried to ping the controllers. The r2 and first s64 ping fine. The other s64 responds with expired in transit.

I ended up getting the old strategy back to running. There were some issues due to running dual networks. Does any have any samples of moving floats to the scratch pad?


#2

Can you show us the code you had?


#3

It won’t let me upload an attachment. new user


#4

We do that to limit spam on the forums… I have just adjusted your user level, you should be able to upload attachments now.


#5

Thank you. I do appreciate it. Philip, the action block that I added was part of the Air Unit charts. Block 927. Right now it references From TTNC, but I actually need to move AU_Temperature (a float array).
With Changes.zip (53.7 KB)


#6

The following is meant to be constructive criticism:

That strategy is a mess. If this was written in-house then you really should spend some time to clean it up, give the blocks some names and drop in some comments. If you had this written by someone else, I just wanted to let you know that the quality of the flowchart/programming should not cause you to dismiss Opto22 in favor of AB as this is not a very good example of a quality strategy. Debugging/troubleshooting that strategy has got to be near impossible.

Now, on to your issue. It is hard to follow the logic in that chart and I don’t know the reasoning for the ANALOG_POINTER variable in your index, but it looks like you can just write all 100 elements of the AU_TEMPERATURE table to the scratchpad, as I don’t see the scratchpad being used for anything else in your strategy.

See the second command in the action block image. I left your command in there for comparison, you should delete that and then write the whole table at one time using the command I added.

Just make sure that this block gets called at an appropriate rate for your process.

image


#7

Always appreciate constructive criticism, especially while drowning. I’m glad to know that this was not a shining example of an Opto strategy. Once I have this setup, from what I understand, I then need to use the ethernet configurator to setup assembly instances in order to access the scratch pad from AB. Can you confirm?

Also, Thanks Beno. I definitely understand the intent to limit spam. I’ve seen a lot of decent forums overrun. Thanks for the adjustment.


#8

Best to prevent drowning by starting with a boat without too many holes in it. :wink:

I do not have experience with the ethernet configurator, but looking at the docs, that sounds like the correct approach.


#9

Thanks for all the help.


#10

Your welcome, good luck and let us know how it turns out.