OPTO Datalink terminates unexpectedly


#1

Hi,
A customer is facing this problem while developing a fairly large application: When the PC is started, OPTO datalink shows in the Win task manager, as it should. Then, in 30 seconds it disappears with a Win event log:
OptoDataLinkRuntime service terminated unexpectedly. It has done this 1 time(s).
Event ID: 7034
Starting the opto datalink configurator, it says that OptoDataLinkRuntime cannot be restarted, and that they should reboot.

I am not sure how they should start debugging.

The background info:[INDENT]Win XP
Project Pro 8.5
The application was developed on 3 PC’s by 3 persons, then they were merged (I mean the project parts, not the developers :wink:
[/INDENT]Any help is appreciated.


#2

Hi Com-Forth,

Welcome to the forums.
First up, please email this issue to Opto’s Product Support Group, support@opto22.com
They can get started working on the issue, and can engage with the software engineer that wrote the app if need be.
Get that email off so that process can start, the forums are more for idea exchanging rather than hard troubleshooting.
That’s not to say that someone might not have a solution, it just might take longer for them to see your post and reply…

Thanks.

Ben.


#3

Was any progress made on this? I routinely get the same error with even a very simple OptoDatalink setup.


#4

Yes, the issue was resolved. Here is the Opto support engineer’s prescription that helped:
>>In OptoDataLink Configurator, […] go to the Run menu and choose Stop All. That will stop the service, delete the runtime.xml file in the Pac Project folder, and start the service again.<<


#5

Thanks bonapeti, will give it a shot.


#6

While I’m not sure what exactly triggers the problem… just closing OptoDataLink and reopening it seems to be enough, even clicking “Stop All” gives me this:


I also get a Java JIT debugger pop sometimes telling me a connection was refused. Either way it means a reboot.

BC


#7


Here is message I got after changing some parameters in one datalink and trying to restart it.


#8

So when I do “Stop All”, the detail in that error shows it can’t delete runtime.xlm… presumably the service has it open. Following that error, I have to reboot to have another go at it.

************** Exception Text **************
System.IO.IOException: The process cannot access the file ‘C:\Program Files (x86)\Opto22\PAC Project 9.1\runtime.xml’ because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.Delete(String path)
at ODLConfiguration.ConfigurationForm.stopAllDataflows()
at ODLConfiguration.ConfigurationForm.menuRunStopAll_Click(Object sender, EventArgs e)
at System.Windows.Forms.MenuItem.OnClick(EventArgs e)
at System.Windows.Forms.MenuItem.MenuItemData.Execute()
at System.Windows.Forms.Command.Invoke()
at System.Windows.Forms.Command.DispatchID(Int32 id)
at System.Windows.Forms.Control.WmCommand(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


#9

Hi All,
Sorry you’re having trouble. My favorite OptoDataLink expert suggests this: "Stop the service, delete runtime.xml from the PAC Project install folder, and restart the service. That’s what the Stop All menu item does as a convenience, but it seems like something is still holding the file open, so the Stop All thing isn’t working."
Have you tried something like that?
Thanks,
-OptoMary