Multiple Charts Running and I/O Configuration

This information might be very clear somewhere on the manual, I am new to Opto22 products and PAC control, I hope I can get some clarification here:

  • I have a PAC control project running 5 Charts, in addition to the powerup chart.
  • If I set a loop on any of the charts, it will get stuck on that loop and not continue on any of the other charts.
  • The way I have it working is by having a loop on the powerup chart, and basically run the charts one at the time, so the chart will start and stop, then return to the powerup chart and continue to the next one.
  • I know from the manual that charts can be running simultaneously, buy I am unsure of how the powerup instruction should initialize them, and how the delays play a role in the sequence.
  • I am attaching my PAC control software as it is, its compiling and working, but hoping to get some guidance to understand if it could be done better in terms of the loops.

In addition to that, my IO unit keeps resetting the configuration after power cycle, so it only runs after I manually stop and start the Strategy, its a Groove Epic Unit, I read in another forum some information about it:

“One way to save a configuration to flash is enter debug mode in PAC Control. Double-click on the I/O unit in the strategy tree. In the window that opens, click on the Information tab. Click Set under Stored Configuration (Flash EEPROM). A message will pop up saying “EEPROM written successfully” to inform you that the write was successful.”

I will give that a try. it would be good to know if there are any other recommended, or preferred way of doing it.

Thank you (221.7 KB)

I’m sure there will be other comments to this thread, but in the mean time, take a close look at the best practices guide that Opto has put together, it should help guide you on a lot of these questions.

I took a look at your strategy, thanks for posting it, makes things a lot easier when answering.

Each of your charts looks like it could be a looping chart. Just be sure to add a delay to each chart, just one delay, even around 10msec would be fine.

In your power-up chart, have an action block that starts each of the other charts using the ‘Start Chart’ command.
Do not loop the power-up chart, there is no need to restart the charts over and over.
So your power up chart will end up having one action block that starts all the other charts and nothing more.

In your I/O configuration in PAC Control, remove the IP address and tick the box ‘Local (Loopback)’.

I suspect that it is not so much your IO unit that is resetting after a power cycle, but your key variables.
None of them are ‘persistent’. Any variables that you want remembered after a power cycle need to be of the type persistent. Change them in PAC Control configure mode.

If you do need to sequence your charts, you can do it by combining the two charts into one that need to run in sequence (I am assuming from your power up chart structure that you want the ‘enable’ chart to run before the ‘reset’ chart), or you could have a looping chart that does a similar action to your current power-up chart, again, just be sure to have a small delay in the loop.
(I noticed that your current power-up chart does not have any delays in it, that’s bad).