Is It Possible to Get Node-RED to Talk to PAC Sim?


#1

My PAC R2 just bit the dust in the middle of a huge project of which Node-RED is a large part. I don’t see a way to set the API key so Node-RED isn’t working. Is this correct?

Thanks,

Dave


#2

The Node-RED PAC Node uses the RESTful API to get the data in and out of a PAC Controller.
For now, SoftPAC does not have that interface (as you have discovered).

(I am a bit surprised to hear about the R2, have you tried a factory reset?).


#3

That’s what I thought.

Yes, I did a factory reset and that solved my problem at the time. However, just tried to connect to my PAC with PAC Terminal and I can’t. This is the second PAC R2 I’ve had this problem with. The fix is to go into PAC Manager and restart the PAC there. The problem is this happens daily whenever I do any development. Very frustrating.

I opened a support case for my other issue and they traced it to using two comm handles with the same name in different charts. However they mentioned there might be some other issues with the firmware code. That one is using B9.5G. The one I’m having problems with is using 9.5D. There has to be something in the firmware code because these two R2s are in completely different environments. The first one is a full blown app running many charts but this one has one chart with two blocks. All it does is initialize three tables.

I opened a support case for the new issue so we’ll see what they come up with next week.

Dave