Groov Tag Scale or Scale Factor


#1

I updated my Groov server today to the current version. If I configure a tag with a scale or use the Scale Factor on a round gauge, it doesn’t seem to work. I know the Scale Factor worked with a round gauge on my previous version. Maybe I’m doing something wrong?


#3

Is that a scale on the gadget, or on a Modbus tag?


#4

I already had a project developed. Then, I upgraded to newest version of groov. The scale factor of the gauge gadget stopped working. Ok, so I put the scale factor to 1 and tried to scale it in the Modbus tag section. Still didn’t work. So I deleted the tag and recreated the tag and both the scale factor and scaling the Modbus tag worked just fine. I can’t remember what version I upgraded from. I’ll look when I get home.


#5

I have noticed this phenomenon on a few tags. Many times I have had to delete a tag and recreate it to get it working again. I think it’s one of those things in GROOV.

My last example was with the camera proxy. When I edited the existing video tag it wouldn’t work. I then had to delete the old tag and create it again with proxy ticked, and it worked.
Same story with a few of my modbus devices. When I’m configuring or fault finding, I delete a tag and recreate it with the new settings.


#6

Just to clear up a bit of terminology:

A Tag is a data source on a device. It’s what groov View reads and writes from/to.

A Gadget is the thing we use to render those data sources. In particular a Video gadget doesn’t have a tag data source.

So when you say you’re deleting tags and recreating them, are you referring to gadgets, tags, or both?


#7

I’m referring to the tag that you configure for each device that groov reads/writes from/to. When I upgraded groov, the scale factor of the Gauge Gadget quit working and groov displayed it as RAW Data from my Modbus device. I did not delete the Gauge Gadget. I just set the scale factor to 1 and then went to the “Device Config” area and tried to lineal scale the value. It did not work. My Gauge still showed the data as RAW from my Modbus device. So I went to the “Device Config” area and deleted the tag and recreated it. Then, since I deleted the tag, my Gauge Gadget did not have a tag assigned. I reassigned it and then everything worked.


#8

Apologies, Jonathan.
You are correct and I am referring to gadgets to be specific.