Groov Refresh Rate

I have a refresh rate problem in my Groov. I have two buttons that write a one or a zero to a PAC table and Modbus register on a different device, respectively. Both devices are on the same network and same subnet. When I click the button associated with the PAC, it updates the table immediately but the button doesn’t reflect the change in status, or if it does it takes as long as two minutes. Identical button pointing to my Modbus device writes the register immediately and updates the button in Groov at the same time.

I’ve tried both Chrome and IE on two different computers with the same results.

Why is this?

Here are the visuals;

Both buttons off:

Both pressed at the same time:


Are you on the latest version of groov (4.0a)? This was a known issue in the 3.5 releases.

1 Like

I’m not but I will be shortly. :wink: I’ll let you know how it works.


That fixed it.

Thanks again.

1 Like

B4.0c Solves a refresh problem I had too. Thanks Jonathan! :smile:

1 Like

Norm, your issue is likely to only ever be seen on the mobile clients, though it can affect desktops as well. It ended up being a one line fix: I maintain a set of active tag data subscriptions that’s indexable in two different ways, and I forgot to clear one of the indexes when a subscription expired.

So the phone goes to sleep (or just lock it), wait 3 minutes or so, the subscription expires and is cleared from the primary set, but the secondary index entry was still there, leaving me with zombie subscriptions.

(Also, your beta is numbered 4.0c. 4.0b hasn’t actually been released yet, but we’re on schedule for it to clear QA this week.)