Getting error when access to API data

I try to create a credential for my EPIC API in order to get the PAC Control API data.


Even I set the user to System Administrator, it also having the same error.

I can only get the API data with the startup/default user account

How do I give the 2nd account permission to access the API data?

Sorry to say this, but I am very confused by what you are tying to do… Can you help us help by telling us a bit more about what you are trying to get done?

Im confused because you don’t need two sets of API keys.
You use the EPIC when talking to the EPIC and you generally don’t need the PAC Control API at all.
The PAC Control API is not needed when using EPIC.
The URL you showed before you edited the post is the PAC Control HTTPS URL for setting the user and keys. That will not work on the EPIC and generally is not needed when working with the PAC Control API either, just set PAC Manager to http and you are up and running.

Can you start by explaining what application you are using on the EPIC and what service on the PAC Controller that requires an API key?

Sorry for not stating it clearly.
Actually, we developed a control panel website to control the EPIC devices for the alarm system. The communication protocol decided to use is REST API.

In my first post, I created a user named jun. I set Read-Write for PAC Control REST API access to this user. But when I try to get the API data using cURL, it shows me an error message about the invalid key/ID value. That’s why I tried to access the /admin/creds but this is only available for snap-pac devices.

After that, I tried to set the jun user as the system administrator and test again, but failed also. Then, I tested using the default system administrator, and its success. I just don’t understand why the jun user failed to read/write the API data.

Sounds like a cache issue.
Your second account should have worked.
Is it possible to restart the EPIC?

Ahhh, now it works. Is this mean every time after modification on user rights, we have to restart the EPIC to release the cache to apply the changes?

Of course I want to say no… But… Can you quickly check the help - > about and tell us what version firmware you are running?
I’d like to run this up the software engineers flagpole and see what they say.

Sure, the system version is 3.4.2-b.102.

No, restarting shouldn’t be necessary, I’ll give it a look here.