FT232H to Flash

I am trying to talk to a flash microchip (ST M25P16 200 mil SOIC-8) with the FT232H breakout board.

This is what my board looks like:

I am really trying to talk to the chip through a GROOV EPIC microcontroller through SSH PUTTY. Through this way, I can only get to trying to talk to the chip by git cloning to the site on putty through “git clone https://github.com/optodeveloper/SSH-Demo.git” through that, I talked to the USB port through “/dev/ttySer1” and it came out as: Permission denied. I tried “ls /dev/ttySer1”, but it only gave me a symbolink of “/dev/ttySer1” All of what I am trying to do can be found on page 70 of (https://documents.opto22.com/2267_groov_EPIC_Users_Guide.pdf)

I have tried downloading multiple things and looking online for an answer on how to continue, but I cannot figure this out. This includes Zadig and Libftdi.orig.tar.bz2 and build1.debian.tar.xz. Maybe it is how I built my breadboard? Any help on how to continue to try and read and write to this chip through the FT232H would be greatly appreciated.

Thank you in advance for your help, and please ask me as many questions as necessary to try and figure this out.

I think the FT232 board emulates a serial port, just to test things out (I know you want to use shell in the long run, but just hear me out) try using Node-RED.
It supports serial I/O and you may be able to test a few things using that via the serial Nodes.

Well, as I said, all of what I am trying to do is on page 70 of the EPIC users guide. So I should be able to do this through SSH. It says use /dev/ttySer1 to talk to the USB ports and when I do that I get permission denied. I’m thinking I am close, but maybe I am missing something? Maybe someone else has had this problem where they get “permission denied” when trying to talk to the USB? I would like to know what I’m doing wrong when trying to talk to the chip. If anyone could help me specifically with the problem I have explained above, that would be greatly appreciated. Thank you for your time.

Try sudo su and put in your shell password.
This will make you root and you should no longer get the permission notice.

I still get a “Permission denied” but this time it is under root@opto-04-34-1a:/home/micronet/SSH-Demo# instead of micronet@opto-04-34-1a:~/SSH-Demo$, maybe there is something else I am forgetting or not understanding to do before hand? I feel like there could be something I’m missing.

I think what is missing is that your FT232 device is not a supported device.
In short, what that means is that because it does not show up under groov Manage (and I am only guessing here because you have not said either way if it does or not), everything on page 70 does not apply.
You may as well close the users guide in that regard.

So, from shell, cd /dev and then do an ls and see if your usb device shows up.
In an idea world, do the ls before you plug in and then again after and see if anything changes.
If it does not (which I suspect it wont) then it is because the driver is not installed in Linux.

The USB device does show up on my Groov Manage. Doing cd/dev just got me “No such file or directory”

I talked with an Opto 22 engineer and he told me that I should purchase the FT232H device because multiple other users use this device with an SPI protocol to talk to Flash Memory microchips.

“The EPIC system runs a Linux OS, and has secure shell access, which allows you to write custom code to access the onboard USB ports. The part I listed (FT232H) is a GPIO/SPI interface for USB, you could program that to talk to the M25P16 (Flash Memory Microchip), and perform the read/writes necessary. As I said before, we have many applications from our users doing similar custom applications reading from various non standard devices using non standard protocols.”

So I would love to know how others did this! If anyone could please help that would be greatly appreciated. Thank you for your time!

There is a space between the cd and the /dev
cd is change directory.
/ is from root (or the top directory structure)
dev is the device directory.

So the command is cd /dev. Change directory from where you are to root then go into the dev subdirectory.

ls is a list command to see the files in that sub directory.

So I get this:

How do I talk to USB through this?