Node-RED Debug Panel


#1

Can someone tell me why I still have Modbus nodes trying to connect even when the flows they’re associated with are disabled. It makes it almost impossible to work on a flow and check debug values when these errors are coming through once a second. What makes it even worse is that even if I set the debug panel to current flow, it shows me connection errors from every flow.

Thanks


#2

Did you do a full deploy or a partial?
I have found that most times a partial deploy does not clean up unused nodes.


#3

I always do a full deploy.

It has something to do with the modbustcp nodes. That’s where all those are coming from. I suspect they’re written that way. I’m just hoping there’s a fix.


#4

I know why you are getting that. When you deploy have a careful look at the top of your screen and it will tell you that you have unused configuration nodes.

When you connect to a Modbus TCP device there are “hidden” config nodes that do not get deleted when you remove other nodes or flows, these need to get deleted separately.

Let me know if that helps.

Cheers


#5

To quickly see all configured nodes, click on the menu on the top right, then 'Configuration Nodes".
Look for the one that has 0 in it. Double click on it, then delete, lastly you need to do a deploy to remove it.


#6

Thanks for the advice guys, but that’s not the issue. These are nodes that are used in my flow but can’t connect to the TCP/IP devices because they’re not present in my test environment. When I deploy them in my production environment they will start working and the messages will go away. I can’t just delete them because there are too many.

My question is why do I see these messages even though my debug window is set to Current Flow only? I see the message for every modbustcp node in my entire flow, not just the flow I’m working on.

Here’s an example. All my flows are disabled. This tab is blank and set to Current Flow and I’m still getting pounded by these messages.


#7

This is how I solved that annoying custom of the modbus node.

In config, look for the node, edit settings and in the lower part select the flow where you use them most. In that way, debug messages from that node will only appear in that flow.

I hope it helps you


#8

Perfect! Thank you! Now I can get some work done.

:grinning: