Login Bug?


#1

I need some help with this.
See this video:
[video]https://goo.gl/photos/TqBfzxMSd9DU4jic7[/video]

I cannot log in using the virtual keyboard of my device running Chrome on Linux. Ideally I would like to have a login with no credentials (these devices are programmed to only access one page) so, if needed the user could just poke the “login” button and view the assigned page. Another option I would like would be automatic login from specified IP addresses. I have 30 of these and they are each assigned a specific static address. So it would be nice if login wasn’t even required.

Also, HOW DO I GET RID OF THE SECURITY CERTIFICATE WARNING?

Thank you,
Nick


#2

For your certificate warning, try adding the certificate to the certificate store on the chromebook:

chrome://settings/certificates[B][/B]


#3

It’s not a chromebook. It’s an ARM powered touchscreen pc with Linux/Chrome, but I will see if I can do something like that. That is the least of my worries.

Thanks!


#4

Sorry, for some reason I got chromebook in my head - on linux you should be able to add that certificate to the store as well to get rid of the warning.

For the login, have you looked at an add in for chrome, such as Auto Login?


#5

Re the video, you need to ‘tab’ down from password text entry box.
Hit tab twice, once to get the ‘remember’ tick box and then again to highlight the login button.
It is a common thing that I have been seeing on non-pc browsers.

Re logging in without a user/pass. We have talked about internally, but are against turning off that security.
I know it does not help, but we built that functionality into groov view for iOS and groov view for Android for this very reason.
Those apps can be configured with the user/pass and so can go straight into groov from the menu… Using those apps is the ‘official’ way of logging in without needing that first screen.


#6

I don’t have a tab key… Any thought to targeted IP logins/page access?


#7

Arrow key will also work. Just need to move the browser focus from the password button to the login button.

At this point, no. Did you try the plugin that was suggested?


#8

I don’t have arrow keys either (that I saw). This is not Android. Think internet appliance. No apps, widgets, gidgets, gadgets, etc. Everything is coded into the unit. No UI other than the browser UI. This is not Chrome OS either. All program tweaks are done through PuTTy or command terminal on the unit itself. This seems technically like a bug in the groov. Any chance this can get fixed at some point? I can connect a physical keyboard temporarily, but I would rather not have to do this every time a unit is powered off (there are 30 of these).


#9

Hi Nick,

Sorry for taking forever to answer this: I tried to answer back on April 8th but my account wasn’t verified/working yet (I haven’t posted on the forums before), and by the time it was I’d forgotten.

Regarding hitting Enter to log in: that does work in every supported browser: Chrome, IE, Firefox, Safari, and the default browsers on iOS and Android. It logs in using a bog-standard HTML form with a Submit option, so I’m not sure what more we can do there: it seems like maybe your virtual keyboard just isn’t submitting the form normally.

Regarding logging in automatically: if you log into your devices using Kiosk level users, we have an option in Project Settings to not log Kiosk users out. You’ll still have to log in manually once on each device, but after that (assuming cookies get persisted as normal on your devices) they should log in automatically.


#10

I had no luck with your suggestion Jon any ideas?

So after creating a Kiosk level user and having the option to not log Kiosk users out I still have a problem having my system auto login in after a power cycle. Your suggestion works if I do not power cycle the AR1 but I would like to be able to survive a full power cycle of the whole system.

I’m using:

  • A raspberry pi running Raspbian strech with an crontab -e script that runs iceweasel(firefox) on boot.
  • This just opens the AR1 website after one minute to give the AR1 time to fully power on.

#11

Marco, can you describe what you’re seeing in more detail?

First, make sure you’re not using a Private or Incognito mode. Those modes throw out the cookies that web services use to maintain user sessions, so keeping a user logged in won’t work.

Second: does a normal user survive a restart of your AR1? Normal users (including Kiosk ones) should always be able to stay logged in for 2 weeks regardless of any settings in your project. The “don’t log kiosk users out” just extends the lifetime of a session cookie out to 50 years.


#12

Yeah no problem,

I am not calling iceaweasel(firefox) in incognito mode my command is:

iceweasel --new-window --noerrdialogs "https://url_to_oto_device"

Normal users do not survive a restart ether. Also if anyone at OPTO want to see it in person I am in the firmware lab.

To explain my full process in more detail:

Background information

1. Running Raspberry Pi with Raspbian Strech 2. Have a bash script that is ran with crontab @reboot 3. The script runs iceweasel(firefox) after one minute and opens Groov URL 4. All devices are on the same network switch 5. All devices are powered by the same power supply except for SNAP PAC controller

Testing Procedures

1. The main fuse connecting Raspberry Pi, AR1 Box, and SNAP PAC is disconnected 2. Main fuse is reconnected and all devices begin powering on 3. Raspberry Pi is first to start its OS so it waits for one minutes before attempting to open iceweasel(firefox) 4. Groov AR1 boots (blinks its power LED for a bit) 5. Groov AR1 logo lights up and the LED buttons stop blinking indicating its booted (I believe) 6. By now the Pi timer for the browser has expired so the Raspberry Pi opens the Groov URL. 7. Groov page opens asking to log in (uggggggg por que) 8. I get sad :cry:

#13

Do normal users survive a restart if you’re using a normal desktop browser?


#14

I know in my particular situation, the cookies do not survive a power cycle. My devices are simple Linux touch screens that do not “save” any info. A power cycle brings them back to a factory fresh start (well, with my ip and webpage info coded into the config and startup).


#15

My devices are simple Linux touch screens that do not “save” any info.

That right there will keep them from staying logged in. If the cookies set by groov View don’t stay around between restarts, we don’t have any way to associate the browser with a login session.

Were you able to solve the issues you were having with your virtual keyboard?


#16

Yeah, I was simply pointing out why a device might not maintain logins. I am aware of that limitation.

No, I never got the virtual keyboards to work. I would still like to see some sort of IP identification settings on groov’s side that would bypass logins. Such as being able to grant certain IPs access to specific pages. All of my devices have fixed, coded IP LAN addresses that will not change and they have no access to the WAN/internet. In addition, the webpage that gets displayed is coded into the startup configuration of the device. This doesn’t seem to be much of a security issue/threat to me…


#17

Just tested a few login configurations with both iceweasel and chromium and no luck. I manage to bypass the issue of having to use a keyboard with iceweasel since it autofills the login information and I just have to click sign in.

I’m thinking the issue is that the sessions are not maintained after a power cycle as @nickvnlr suggested.

Another thing I just tried is using my desktop instead of the Raspberry pi. Its running windows 10 so nothing fancy. I just leave google chrome with the URL open and then power cycle the AR1.

After the power cycle chrome reloads the page automatically but goes straight to the login.


#18

I’m not sure what changed in the last Groov update, but I can now use the enter button on the screens! Hooray!!!
Status - Fixed (for now)